CVE-2021-32701 is a high-severity (CVSS 7.5) CWE-863 vulnerability in github.com/ory/oathkeeper. A fix is available for github.com/ory/oathkeeper — see the affected versions and patch details below.
Possible bypass of token claim validation when OAuth2 Introspection caching is enabled
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/ory/oathkeeperReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
When you make a request to an endpoint that requires the scope foo using an access token granted with that foo scope, introspection will be valid and that token will be cached. The problem comes when a second requests to an endpoint that requires the scope bar is made before the cache has expired. Whether the token is granted or not to the bar scope, introspection will be valid.
Patches
A patch will be released with v0.38.12-beta.1.
Workarounds
Per default, caching is disabled for the oauth2_introspection authenticator. When caching is disabled, this vulnerability does not exist.
Trace
The cache is checked in func (a *AuthenticatorOAuth2Introspection) Authenticate(...). From tokenFromCache() it seems that it only validates the token expiration date, but ignores whether the token has or not the proper scopes.
Post-Mortem
The vulnerability was introduced in PR #424. During review, we failed to require appropriate test coverage by the submitter which is the primary reason that the vulnerability passed the review process.
To avoid this from happening again we enabled codecov with a strict policy on the Ory Oathkeeper repository: Without an increase in code coverage the PR can not be merged.
To address this issue and any regressions we have added a test suite ensuring that the cache behaviour is correct in the different scenarios:
- Scope strategy is
none, cache is enabled, andrequested_scopeis not empty -> cache will not be used; - Scope strategy is
none, cache is enabled, andrequested_scopeis empty -> cache will be used; - Scope strategy is not
none, cache is enabled, andrequested_scopeis not empty -> cache will be used;
as well as validating if iss, aud, exp, token_use, and scope are validated.
Additionally, we added CodeQL scanning to the CI.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/ory/oathkeeper | ≥ 0.38.0-beta.2&&< 0.38.12-beta.1 | 0.38.12-beta.1go get github.com/ory/oathkeeper@v0.38.12-beta.1 |
Affected Products
oathkeeperoryDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/ory/oathkeeper, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/ory/oathkeeper to 0.38.12-beta.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-32701 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2021-32701 in your dependencies?
Find it across Go, including transitive dependencies.