CVE-2021-32475 — moodle
MEDIUMCVE-2021-32475 is a medium-severity (CVSS 5.4) OS Command Injection vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle stored Cross-site Scripting
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
ID numbers displayed in the quiz grading report required additional sanitizing to prevent a stored XSS risk. Moodle 3.10 to 3.10.3, 3.9 to 3.9.6, 3.8 to 3.8.8, 3.5 to 3.5.17 and earlier unsupported versions are affected.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 3.5&&< 3.5.18 | 3.5.18composer require moodle/moodle:^3.5.18 |
| 🐘Packagist | moodle/moodle | ≥ 3.8&&< 3.8.9 | 3.8.9composer require moodle/moodle:^3.8.9 |
| 🐘Packagist | moodle/moodle | ≥ 3.9&&< 3.9.7 | 3.9.7composer require moodle/moodle:^3.9.7 |
| 🐘Packagist | moodle/moodle | ≥ 3.10&&< 3.10.4 | 3.10.4composer require moodle/moodle:^3.10.4 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 3.5.18 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-32475 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2021-32475 in your dependencies?
Find it across Packagist, including transitive dependencies.