CVE-2021-32090 is a critical-severity (CVSS 9.8) OS Command Injection vulnerability in localstack. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for localstack — see the affected versions and patch details below.
Command injection in LocalStack
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
localstackReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
The dashboard component of StackLift LocalStack 0.12.6 allows attackers to inject arbitrary shell commands via the functionName parameter.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | localstack | all versions | 0.12.10pip install --upgrade 'localstack==0.12.10' |
Affected Products
localstacklocalstackResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for localstack, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update localstack to 0.12.10 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-32090 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2021-32090 in your dependencies?
Find it across PyPI, including transitive dependencies.