NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 GitHub Actions
Not in CISA KEV
HIGH severity

CVE-2021-32074 — vault-action

HIGHFix: hashicorp/vault-action#208

CVE-2021-32074 is a high-severity (CVSS 7.5) CWE-532 vulnerability in hashicorp/vault-action. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for hashicorp/vault-action — see the affected versions and patch details below.

Vault GitHub Action did not correctly mask multi-line secrets in output

Also known asGHSA-4mgv-m5cm-f9h7
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.9%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs79th percentile — riskier than 79% of all scored CVEsHighest risk
0.00%0.79%1.59%2.38%0.3%1.9%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
📦hashicorp/vault-action

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects GitHub Actions packages — download data is not available via public APIs for these ecosystems.

Description

HashiCorp vault-action (aka Vault GitHub Action) before 2.2.0 allows attackers to obtain sensitive information from log files because a multi-line secret was not correctly registered with GitHub Actions for log masking.

The vault-action implementation did not correctly handle the marking of multi-line variables. As a result, multi-line secrets were not correctly masked in vault-action output.

Remediation: Customers using vault-action should evaluate the risk associated with this issue, and consider upgrading to vault-action 2.2.0 or newer. Please refer to https://github.com/marketplace/actions/hashicorp-vault for more information.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦GitHub Actionshashicorp/vault-actionall versions2.2.0

Affected Products

1 product · 1 configurations
Application
vault-actionhashicorp
≥ 0.1.0 && < 2.2.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for hashicorp/vault-action, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update hashicorp/vault-action to 2.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-32074 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

HashiCorp vault-action (aka Vault GitHub Action) before 2.2.0 allows attackers to obtain sensitive information from log files because a multi-line secret was not correctly registered with GitHub Actions for log masking. The vault-action implementation did not correctly handle the marking of multi-line variables. As a result, multi-line secrets were not correctly masked in vault-action output. Remediation: Customers using vault-action should evaluate the risk associated with this issue, and consider upgrading to vault-action 2.2.0 or newer. Please refer to https://github.com/marketplace/actio
O3 Security · Impact-Aware SCA

Is CVE-2021-32074 in your dependencies?

Find it across GitHub Actions, including transitive dependencies.

CVE-2021-32074: vault-action — Fixed in 2.2.0