NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
CRITICAL severity

CVE-2021-3148 — salt

CRITICAL

CVE-2021-3148 is a critical-severity (CVSS 9.8) CWE-77 vulnerability in salt. A fix is available for salt — see the affected versions and patch details below.

SaltStack Salt command injection in the Salt-API when using the Salt-SSH client

Also known asGHSA-ghc2-hx3w-jqmpPYSEC-2021-55
Published
Updated
Affected
9 pkgs
Patched
8 / 9
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
8.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs95th percentile — riskier than 95% of all scored CVEsHighest risk
6.83%7.47%8.11%8.75%7.3%8.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected
🐍salt🐍salt🐍salt🐍salt🐍salt🐍salt🐍salt🐍salt+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in SaltStack Salt before 3002.5. Sending crafted web requests to the Salt API can result in salt.utils.thin.gen_thin() command injection because of different handling of single versus double quotes. This is related to salt/utils/thin.py.

Affected Packages

9 total 8 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIsaltall versions2015.8.13pip install --upgrade 'salt==2015.8.13'
🐍PyPIsalt≥ 2016.3.0&&< 2016.11.52016.11.5pip install --upgrade 'salt==2016.11.5'
🐍PyPIsalt≥ 2016.11.7&&< 2016.11.102016.11.10pip install --upgrade 'salt==2016.11.10'
🐍PyPIsalt≥ 2017.5.0&&< 2017.7.82017.7.8pip install --upgrade 'salt==2017.7.8'
🐍PyPIsalt≥ 2018.2.0No fix
🐍PyPIsalt≥ 2019.2.0&&< 2019.2.82019.2.8pip install --upgrade 'salt==2019.2.8'

Affected Products

3 products · 21 configurations
OS
debian linuxdebian
3 versions
9.010.011.0
OS
fedorafedoraproject
3 versions
323334
Application
saltsaltstack
≥ 3002 && ≤ 2018.3.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for salt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update salt to 2015.8.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3148 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

An issue was discovered in SaltStack Salt before 3002.5. Sending crafted web requests to the Salt API can result in salt.utils.thin.gen_thin() command injection because of different handling of single versus double quotes. This is related to salt/utils/thin.py.
O3 Security · Impact-Aware SCA

Is CVE-2021-3148 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2021-3148: salt — Fixed in 2015.8.13