CVE-2021-3144 — salt
CRITICALCVE-2021-3144 is a critical-severity (CVSS 9.1) CWE-613 vulnerability in salt. A fix is available for salt — see the affected versions and patch details below.
SaltStack Salt eauth tokens can be used once after expiration
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
salt🐍salt🐍salt🐍salt🐍salt🐍salt🐍salt🐍salt+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
In SaltStack Salt before 3002.5, eauth tokens can be used once after expiration. (They might be used to run command against the salt master or minions.)
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | salt | all versions | 2015.8.13pip install --upgrade 'salt==2015.8.13' |
| 🐍PyPI | salt | ≥ 2016.3.0&&< 2016.11.5 | 2016.11.5pip install --upgrade 'salt==2016.11.5' |
| 🐍PyPI | salt | ≥ 2016.11.7&&< 2016.11.10 | 2016.11.10pip install --upgrade 'salt==2016.11.10' |
| 🐍PyPI | salt | ≥ 2017.5.0&&< 2017.7.8 | 2017.7.8pip install --upgrade 'salt==2017.7.8' |
| 🐍PyPI | salt | ≥ 2018.2.0 | No fix |
| 🐍PyPI | salt | ≥ 3000&&< 3000.7 | 3000.7pip install --upgrade 'salt==3000.7' |
Affected Products
debian linuxdebianfedorafedoraprojectsaltsaltstackDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for salt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update salt to 2015.8.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-3144 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Frequently Asked Questions
Is CVE-2021-3144 in your dependencies?
Find it across PyPI, including transitive dependencies.