NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
HIGH severity

CVE-2021-30560 — nokogiri

HIGH

CVE-2021-30560 is a high-severity (CVSS 8.8) Use After Free vulnerability in nokogiri. EPSS puts its 30-day exploitation probability at 20.4% (97th percentile). A fix is available for nokogiri — see the affected versions and patch details below.

Nokogiri has vulnerable dependencies on libxml2 and libxslt

Also known asGHSA-59gp-qqm7-cw4j
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
20.4%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
0.00%9.36%18.7%28.1%0.1%20.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
💎nokogiri

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

Use after free in Blink XSLT in Google Chrome prior to 91.0.4472.164 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsnokogiriall versions1.13.2bundle update nokogiri --conservative

Affected Products

4 products · 7 configurations
OS
debian linuxdebian
2 versions
10.011.0
Application
chromegoogle
< 91.0.4472.164
range
Application
universal forwardersplunk
≥ 9.0.0 && < 9.0.6
1 version
9.1.0
Application
libxsltxmlsoft
< 1.1.35
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nokogiri, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update nokogiri to 1.13.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-30560 is resolved across your whole dependency graph.

  3. Workarounds

    Constrain what reaches the vulnerable code: limit the size and shape of untrusted input, isolate the affected component in a sandboxed or least-privileged process, and enable the platform's memory-safety mitigations (ASLR, stack protector, hardened allocator) so an out-of-bounds access is more likely to fail closed than to be exploitable.

Frequently Asked Questions

Use after free in Blink XSLT in Google Chrome prior to 91.0.4472.164 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page.
O3 Security · Impact-Aware SCA

Is CVE-2021-30560 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2021-30560: nokogiri — Fixed in 1.13.2