NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-30458 — parsoid

MEDIUM

CVE-2021-30458 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in wikimedia/parsoid. A fix is available for wikimedia/parsoid — see the affected versions and patch details below.

Wikimedia Parsoid vulnerable to Cross-site Scripting (XSS)

Also known asGHSA-5pqx-77vf-85rw
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs62th percentile — riskier than 62% of all scored CVEsHighest risk
0.00%0.49%0.99%1.48%0.4%1.0%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘wikimedia/parsoid🐘wikimedia/parsoid

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. An attacker can send crafted wikitext that Utils/WTUtils.php will transform by using a <meta> tag, bypassing sanitization steps, and potentially allowing for XSS.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistwikimedia/parsoid≥ 0.12&&< 0.12.20.12.2composer require wikimedia/parsoid:^0.12.2
🐘Packagistwikimedia/parsoidall versions0.11.1composer require wikimedia/parsoid:^0.11.1

Affected Products

1 product · 2 configurations
Application
parsoidwikimedia
≥ 0.12.0 && < 0.12.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for wikimedia/parsoid, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update wikimedia/parsoid to 0.12.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-30458 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An issue was discovered in Wikimedia Parsoid before 0.11.1 and 0.12.x before 0.12.2. An attacker can send crafted wikitext that Utils/WTUtils.php will transform by using a <meta> tag, bypassing sanitization steps, and potentially allowing for XSS.
O3 Security · Impact-Aware SCA

Is CVE-2021-30458 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-30458: parsoid XSS — Fixed in 0.12.2