NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-30134 — curl

MEDIUMFix: php-mod/curl@0bddefe

CVE-2021-30134 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in php-mod/curl. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for php-mod/curl — see the affected versions and patch details below.

php-mod/curl allows Cross-site Scripting

Also known asGHSA-f8p3-q834-q9cj
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.

Exploitation and automatability from CISA’s SSVC triage for CVE-2021-30134.

EPSS Exploitation Probability

via FIRST.org ↗
1.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs71th percentile — riskier than 71% of all scored CVEsHighest risk
0.76%1.28%1.79%2.30%1.8%1.3%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘php-mod/curl

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

php-mod/curl (a wrapper of the PHP cURL extension) before 2.3.2 allows XSS via the post_file_path_upload.php key parameter and the POST data to post_multidimensional.php.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistphp-mod/curlall versions2.3.2composer require php-mod/curl:^2.3.2

Affected Products

6 products · 6 configurations
Application
ht slider range for amazon affiliatesht_slider_range_for_amazon_affiliates_project
< 1.1.6
range
Application
php curl classphp_curl_class_project
< 2.3.2
range
Application
invoicing with invoicexpress for woocommerceptwooplugins
< 3.0.3
range
Application
woo-qiwi-payment-gatewayqiwi
≤ 0.0.9
range
Application
shopello apishopello_api_project
≤ 2.9.0
range
Application
teamleader crm formsteamleade
< 2.1.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for php-mod/curl, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update php-mod/curl to 2.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-30134 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

How to detect CVE-2021-30134

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2021-30134 -u https://target
Template
Php-mod/curl Library <2.3.2 - Cross-Site Scripting
Severity
medium
Impact
Successful exploitation of this vulnerability could allow an attacker to inject malicious scripts into web pages viewed by users, leading to potential data theft, session hijacking, or defacement.
Remediation
Upgrade to Php-mod/curl Library version 2.3.2 or later to mitigate the vulnerability.

Template by ProjectDiscovery nuclei-templates (theamanrawat), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

php-mod/curl (a wrapper of the PHP cURL extension) before 2.3.2 allows XSS via the post_file_path_upload.php key parameter and the POST data to post_multidimensional.php.
O3 Security · Impact-Aware SCA

Is CVE-2021-30134 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-30134: curl XSS — Fixed in 2.3.2