CVE-2021-29482 is a high-severity (CVSS 7.5) CWE-835 vulnerability in github.com/ulikunitz/xz. A fix is available for github.com/ulikunitz/xz — see the affected versions and patch details below.
github.com/ulikunitz/xz fixes readUvarint Denial of Service (DoS)
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
github.com/ulikunitz/xzReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.
Description
Impact
xz is a compression and decompression library focusing on the xz format completely written in Go. The function readUvarint used to read the xz container format may not terminate a loop provide malicous input.
Patches
The problem has been fixed in release v0.5.8.
Workarounds
Limit the size of the compressed file input to a reasonable size for your use case.
References
The standard library had recently the same issue and got the CVE-2020-16845 allocated.
For more information
If you have any questions or comments about this advisory:
- Open an issue in xz.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐹Go | github.com/ulikunitz/xz | all versions | 0.5.8go get github.com/ulikunitz/xz@v0.5.8 |
Affected Products
xzxz_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/ulikunitz/xz, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update github.com/ulikunitz/xz to 0.5.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-29482 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
In OpenShift Container Platform (OCP), OpenShift ServiceMesh (OSSM) and Red Hat Advanced Cluster Management for Kubernetes (RHACM) the affected components are behind OpenShift OAuth authentication, therefore the impact is low. In OCP before 4.7 the buildah, skopeo and podman packages include vulnerable version of…
| Product | Fixed in | Advisory |
|---|---|---|
| OADP-1.0-RHEL-8 | oadp/oadp-velero-plugin-rhel8:1.0.1-5 | RHSA-2022:0687 |
| OpenShift Service Mesh 2.0 | servicemesh-0:2.0.9-3.el8 | RHSA-2022:1276 |
| Red Hat OpenStack Platform 16.2 | rhosp-rhel8-tech-preview/osp-director-operator:1.2.3-2 | RHSA-2022:2183 |
| RHEL-8-CNV-4.8 | container-native-virtualization/vm-import-operator-rhel8:v4.8.0-18 | RHSA-2021:2920 |
Frequently Asked Questions
Is CVE-2021-29482 in your dependencies?
Find it across Go, including transitive dependencies.