NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐹
🐹 Go
Not in CISA KEV
MEDIUM severity

CVE-2021-27940 — orchestrator

MEDIUMFix: openark/orchestrator#1313

CVE-2021-27940 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in github.com/openark/orchestrator. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for github.com/openark/orchestrator — see the affected versions and patch details below.

openark/orchestrator cross-site scripting vulnerability

Also known asGHSA-752c-vfpf-cp2w
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs69th percentile — riskier than 69% of all scored CVEsHighest risk
0.00%0.58%1.16%1.75%0.4%1.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐹github.com/openark/orchestrator

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Go packages — download data is not available via public APIs for these ecosystems.

Description

resources/public/js/orchestrator.js in openark orchestrator before 3.2.4 allows XSS via the orchestrator-msg parameter.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐹Gogithub.com/openark/orchestratorall versions3.2.4go get github.com/openark/orchestrator@v3.2.4

Affected Products

1 product · 1 configurations
Application
orchestratoropenark
< 3.2.4
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for github.com/openark/orchestrator, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update github.com/openark/orchestrator to 3.2.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-27940 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

resources/public/js/orchestrator.js in openark orchestrator before 3.2.4 allows XSS via the orchestrator-msg parameter.
O3 Security · Impact-Aware SCA

Is CVE-2021-27940 in your dependencies?

Find it across Go, including transitive dependencies.

CVE-2021-27940: orchestrator XSS — Fixed in 3.2.4