NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🦀
🦀 crates.io
Not in CISA KEV
MEDIUM severity

CVE-2021-27671 — comrak

MEDIUMFix: kivikakk/comrak@b3efbb6

CVE-2021-27671 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in comrak. A fix is available for comrak — see the affected versions and patch details below.

Cross site scripting in comrak

Also known asGHSA-xmr7-v725-2jjrRUSTSEC-2021-0026
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs53th percentile — riskier than 53% of all scored CVEsHighest risk
0.00%0.40%0.79%1.19%0.2%0.7%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🦀comrak

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.

Description

An issue was discovered in the comrak crate before 0.9.1 for Rust. Cross site scripting (XSS) can occur because the protection mechanism for data: and javascript: URIs is case-sensitive, allowing (for example) Data: to be used in an attack.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🦀crates.iocomrakall versions0.9.1cargo update -p comrak --precise 0.9.1

Affected Products

1 product · 1 configurations
Application
comrakcomrak_project
< 0.9.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for comrak, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update comrak to 0.9.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-27671 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

An issue was discovered in the comrak crate before 0.9.1 for Rust. Cross site scripting (XSS) can occur because the protection mechanism for data: and javascript: URIs is case-sensitive, allowing (for example) Data: to be used in an attack.
O3 Security · Impact-Aware SCA

Is CVE-2021-27671 in your dependencies?

Find it across crates.io, including transitive dependencies.

CVE-2021-27671: comrak XSS — Fixed in 0.9.1