NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2021-26118 — artemis-openwire-protocol

HIGHFix: apache/activemq-artemis@e5566d5

CVE-2021-26118 is a high-severity (CVSS 7.5) CWE-284 vulnerability in org.apache.activemq:artemis-openwire-protocol. A fix is available for org.apache.activemq:artemis-openwire-protocol — see the affected versions and patch details below.

Apache ActiveMQ Artemis vulnerable to Improper Access Control

Also known asGHSA-q7fr-vqhq-v5xr
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 1, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
3.9%probability of exploitation in next 30 days
Lower Risk-0.06%
Lower risk than most CVEs90th percentile — riskier than 90% of all scored CVEsHighest risk
0.11%1.71%3.31%4.91%1.0%3.9%May 26Aug 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.apache.activemq:artemis-openwire-protocol

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

While investigating ARTEMIS-2964 it was found that the creation of advisory messages in the OpenWire protocol head of Apache ActiveMQ Artemis 2.15.0 bypassed policy based access control for the entire session. Production of advisory messages was not subject to access control in error.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.apache.activemq:artemis-openwire-protocolall versions2.16.0org.apache.activemq:artemis-openwire-protocol:2.16.0

Affected Products

2 products · 2 configurations
Application
artemisapache
1 version
2.15.0
Application
oncommand workflow automationnetapp
all

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.apache.activemq:artemis-openwire-protocol, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.apache.activemq:artemis-openwire-protocol to 2.16.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-26118 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
Workaround published by Red Hat
If you are not using the openwire protocol, it can be disabled by removing it from the list of accepted protocols in the `broker.xml` ```xml <acceptor name="artemis">tcp://0.0.0.0:61616?tcpSendBufferSize=1048576;tcpReceiveBufferSize=1048576;amqpMinLargeMessageSize=102400;protocols=CORE,AMQP,STOMP,HORNETQ,MQTT;useEpoll=true;amqpCredits=1000;amqpLowCredits=300;amqpDuplicateDetection=true</acceptor> ```
Source: Red Hat security advisory for CVE-2021-26118 (CC BY 4.0)

Frequently Asked Questions

While investigating ARTEMIS-2964 it was found that the creation of advisory messages in the OpenWire protocol head of Apache ActiveMQ Artemis 2.15.0 bypassed policy based access control for the entire session. Production of advisory messages was not subject to access control in error.
O3 Security · Impact-Aware SCA

Is CVE-2021-26118 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-26118: artemis-openwire — Fixed in 2.16.0