CVE-2021-25971 is a medium-severity (CVSS 4.3) CWE-248 vulnerability in camaleon_cms. A fix is available for camaleon_cms — see the affected versions and patch details below.
Camaleon CMS vulnerable to Uncaught Exception
Exploitation Status
Proof-of-concept exploit code exists
- CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
Exploitation and automatability from CISA’s SSVC triage for CVE-2021-25971.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
camaleon_cmsReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
In Camaleon CMS, versions 2.0.1 to 2.6.0 are vulnerable to an Uncaught Exception. The app's media upload feature crashes permanently when an attacker with a low privileged access uploads a specially crafted .svg file
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | camaleon_cms | ≥ 2.0.1&&< 2.6.0.1 | 2.6.0.1bundle update camaleon_cms --conservative |
Affected Products
camaleon cmstuzitioDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for camaleon_cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update camaleon_cms to 2.6.0.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-25971 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2021-25971 in your dependencies?
Find it across RubyGems, including transitive dependencies.