CVE-2021-25959 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in org.opencrx:opencrx-core. A fix is available for org.opencrx:opencrx-core — see the affected versions and patch details below.
Cross-site Scripting in OpenCRX
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.opencrx:opencrx-core☕org.opencrx:opencrx-core-models☕org.opencrx:opencrx-core-config☕org.opencrx:opencrx-client☕org.opencrx:opencrx-gradleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
In OpenCRX, versions v4.0.0 through v5.1.0 are vulnerable to reflected Cross-site Scripting (XSS), due to unsanitized parameters in the password reset functionality. This allows execution of external javascript files on any user of the openCRX instance.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.opencrx:opencrx-core | ≥ 4.0.0&&< 5.2.0 | 5.2.0org.opencrx:opencrx-core:5.2.0 |
| ☕Maven | org.opencrx:opencrx-core-models | ≥ 4.0.0&&< 5.2.0 | 5.2.0org.opencrx:opencrx-core-models:5.2.0 |
| ☕Maven | org.opencrx:opencrx-core-config | ≥ 4.0.0&&< 5.2.0 | 5.2.0org.opencrx:opencrx-core-config:5.2.0 |
| ☕Maven | org.opencrx:opencrx-client | ≥ 4.0.0&&< 5.2.0 | 5.2.0org.opencrx:opencrx-client:5.2.0 |
| ☕Maven | org.opencrx:opencrx-gradle | ≥ 4.0.0&&< 5.2.0 | 5.2.0org.opencrx:opencrx-gradle:5.2.0 |
Affected Products
opencrxopencrxDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.opencrx:opencrx-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.opencrx:opencrx-core to 5.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-25959 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2021-25959 in your dependencies?
Find it across Maven, including transitive dependencies.