CVE-2021-25281 — salt
CRITICALCVE-2021-25281 is a critical-severity (CVSS 9.8) Improper Authentication vulnerability in salt. 5 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for salt — see the affected versions and patch details below.
SaltStack Salt Improper Authentication vulnerability
Exploitation Status
No confirmed exploitation observed yet
- CISA assesses this as automatable — exploitation doesn’t require manual, per-target effort, which raises the odds of mass scanning and opportunistic attacks.
- A successful exploit gives an attacker total control of the affected component, not partial access.
- CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.
Exploitation and automatability from CISA’s SSVC triage for CVE-2021-25281.
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
salt🐍salt🐍salt🐍salt🐍salt🐍salt🐍salt🐍salt+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in through SaltStack Salt before 3002.5. salt-api does not honor eauth credentials for the wheel_async client. Thus, an attacker can remotely run any wheel modules on the master.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | salt | all versions | 2015.8.13pip install --upgrade 'salt==2015.8.13' |
| 🐍PyPI | salt | ≥ 2016.3.0&&< 2016.11.5 | 2016.11.5pip install --upgrade 'salt==2016.11.5' |
| 🐍PyPI | salt | ≥ 2016.11.7&&< 2016.11.10 | 2016.11.10pip install --upgrade 'salt==2016.11.10' |
| 🐍PyPI | salt | ≥ 2017.5.0&&< 2017.7.8 | 2017.7.8pip install --upgrade 'salt==2017.7.8' |
| 🐍PyPI | salt | ≥ 2018.2.0 | No fix |
| 🐍PyPI | salt | ≥ 2019.2.0&&< 2019.2.8 | 2019.2.8pip install --upgrade 'salt==2019.2.8' |
Affected Products
debian linuxdebianfedorafedoraprojectsaltsaltstackResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for salt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update salt to 2015.8.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-25281 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
How to detect CVE-2021-25281
A community-maintained Nuclei template exists for this CVE. You can scan for it directly:
nuclei -id cve-2021-25281 -u https://target- Template
- SaltStack Salt <3002.5 - Auth Bypass
- Severity
- critical
- Impact
- Unauthenticated attackers can remotely execute any wheel modules on the Salt master by bypassing eauth credentials, leading to complete infrastructure compromise and control over all managed systems.
- Remediation
- Upgrade to SaltStack Salt version 3002.5 or later to mitigate this vulnerability.
Template by ProjectDiscovery nuclei-templates (madrobot), MIT licensed. View the full template. Scan only systems you are authorised to test.
Frequently Asked Questions
Is CVE-2021-25281 in your dependencies?
Find it across PyPI, including transitive dependencies.