NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-24323 — woocommerce

MEDIUMFix: woocommerce/woocommerce@6ede8c5

CVE-2021-24323 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in woocommerce/woocommerce. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for woocommerce/woocommerce — see the affected versions and patch details below.

Woocommerce Cross-site Scripting via Additional tax classes field when taxes are enabled

Also known asGHSA-mp46-7x6q-f28m
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.41%0.83%1.24%0.4%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘woocommerce/woocommerce

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

When taxes are enabled, the "Additional tax classes" field was not properly sanitised or escaped before being output back in the admin dashboard, allowing high privilege users such as admin to use XSS payloads even when the unfiltered_html is disabled

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistwoocommerce/woocommerceall versions5.2.0composer require woocommerce/woocommerce:^5.2.0

Affected Products

1 product · 1 configurations
Application
woocommercewoocommerce
< 5.2.0
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for woocommerce/woocommerce, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update woocommerce/woocommerce to 5.2.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-24323 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

When taxes are enabled, the "Additional tax classes" field was not properly sanitised or escaped before being output back in the admin dashboard, allowing high privilege users such as admin to use XSS payloads even when the unfiltered_html is disabled
O3 Security · Impact-Aware SCA

Is CVE-2021-24323 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-24323: woocommerce XSS — Fixed in 5.2.0