NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2021-23639 — md-to-pdf

CRITICALFix: simonhaenisch/md-to-pdf@a716259

CVE-2021-23639 is a critical-severity (CVSS 9.8) remote code execution vulnerability in md-to-pdf. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for md-to-pdf — see the affected versions and patch details below.

Code Injection in md-to-pdf.

Also known asGHSA-x949-7cm6-fm6pSNYK-JS-MDTOPDF-1657880
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.4%probability of exploitation in next 30 days
Lower Risk+0.08%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
0.96%8.73%16.5%24.3%19.9%5.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

81other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
md-to-pdfnpm
262Kdownloads / week

Description

The package md-to-pdf before 5.0.0 are vulnerable to Remote Code Execution (RCE) due to utilizing the library gray-matter to parse front matter content, without disabling the JS engine.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmmd-to-pdfall versions5.0.0npm install md-to-pdf@5.0.0

Affected Products

1 product · 1 configurations
Application
markdown to pdfmarkdown_to_pdf_project
< 5.0.0
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for md-to-pdf, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update md-to-pdf to 5.0.0 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-23639 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

The package md-to-pdf before 5.0.0 are vulnerable to Remote Code Execution (RCE) due to utilizing the library gray-matter to parse front matter content, without disabling the JS engine.
O3 Security · Impact-Aware SCA

Is CVE-2021-23639 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2021-23639: md-to-pdf RCE — Fixed in 5.0.0