NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2021-21628 — build-with-parameters

MEDIUMFix: jenkinsci/build-with-parameters-plugin@edbc286

CVE-2021-21628 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in org.jenkins-ci.plugins:build-with-parameters. EPSS puts its 30-day exploitation probability at 81.4% (100th percentile). A fix is available for org.jenkins-ci.plugins:build-with-parameters — see the affected versions and patch details below.

Stored XSS vulnerability in Jenkins Build With Parameters Plugin

Also known asGHSA-xjrg-6fv9-6rjg
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
81.4%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
0.00%33.3%66.7%100.0%1.3%81.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:build-with-parameters

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins Build With Parameters Plugin 1.5 and earlier does not escape parameter names and descriptions.

This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission.

Jenkins Build With Parameters Plugin 1.5.1 escapes parameter names and descriptions.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:build-with-parametersall versions1.5.1org.jenkins-ci.plugins:build-with-parameters:1.5.1

Affected Products

1 product · 1 configurations
Application
build with parametersjenkins
≤ 1.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:build-with-parameters, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:build-with-parameters to 1.5.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-21628 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Jenkins Build With Parameters Plugin 1.5 and earlier does not escape parameter names and descriptions. This results in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Job/Configure permission. Jenkins Build With Parameters Plugin 1.5.1 escapes parameter names and descriptions.
O3 Security · Impact-Aware SCA

Is CVE-2021-21628 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-21628: build-with XSS — Fixed in 1.5.1