NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2021-21625 — aws-credentials

MEDIUMFix: jenkinsci/aws-credentials-plugin@dd477a0

CVE-2021-21625 is a medium-severity (CVSS 4.3) CWE-862 vulnerability in org.jenkins-ci.plugins:aws-credentials. A fix is available for org.jenkins-ci.plugins:aws-credentials — see the affected versions and patch details below.

Missing permission checks in Jenkins CloudBees AWS Credentials Plugin allows enumerating credentials IDs

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.42%0.83%1.25%0.0%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.jenkins-ci.plugins:aws-credentials

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

CloudBees AWS Credentials Plugin 1.28 and earlier does not perform a permission check in a helper method for HTTP endpoints.

This allows attackers with Overall/Read permission to enumerate credentials IDs of AWS credentials stored in Jenkins if any of the following plugins are installed:

Credentials IDs obtained this way can be used as part of an attack to capture the credentials using another vulnerability.

CloudBees AWS Credentials Plugin 1.28.1 performs permission checks in the helper method for HTTP endpoints.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.plugins:aws-credentialsall versions1.28.1org.jenkins-ci.plugins:aws-credentials:1.28.1

Affected Products

1 product · 1 configurations
Application
cloudbees aws credentialsjenkins
≤ 1.28
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:aws-credentials, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.plugins:aws-credentials to 1.28.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-21625 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

CloudBees AWS Credentials Plugin 1.28 and earlier does not perform a permission check in a helper method for HTTP endpoints. This allows attackers with Overall/Read permission to enumerate credentials IDs of AWS credentials stored in Jenkins if any of the following plugins are installed: - [Amazon Elastic Container Service (ECS) / Fargate](https://plugins.jenkins.io/amazon-ecs) - [AWS Parameter Store Build Wrapper](https://plugins.jenkins.io/aws-parameter-store) - [AWS SAM](https://plugins.jenkins.io/aws-sam)\n\nFurther plugins may use this helper method as well without performing a permissi
O3 Security · Impact-Aware SCA

Is CVE-2021-21625 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2021-21625: aws-credentials — Fixed in 1.28.1