NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-21029 — community-edition

MEDIUMFix: magento/magento2@a2eb7e2

CVE-2021-21029 is a medium-severity (CVSS 4.8) Cross-site Scripting (XSS) vulnerability in magento/community-edition. EPSS puts its 30-day exploitation probability at 84.6% (100th percentile). A fix is available for magento/community-edition — see the affected versions and patch details below.

Magento Reflected Cross-site Scripting vulnerability via 'file' parameter

Also known asBIT-magento-2021-21029GHSA-jwxh-wj79-ccm6
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
84.6%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
31.1%53.1%75.1%97.0%43.5%84.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘magento/community-edition🐘magento/community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a Reflected Cross-site Scripting vulnerability via 'file' parameter. Successful exploitation could lead to arbitrary JavaScript execution in the victim's browser. Access to the admin console is required for successful exploitation.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-editionall versions2.3.6-p1composer require magento/community-edition:^2.3.6-p1
🐘Packagistmagento/community-edition≥ 2.4.0&&< 2.4.22.4.2composer require magento/community-edition:^2.4.2

Affected Products

1 product · 10 configurations
Application
magentomagento
< 2.3.6
3 versions
2.3.62.4.02.4.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.3.6-p1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-21029 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by a Reflected Cross-site Scripting vulnerability via 'file' parameter. Successful exploitation could lead to arbitrary JavaScript execution in the victim's browser. Access to the admin console is required for successful exploitation.
O3 Security · Impact-Aware SCA

Is CVE-2021-21029 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-21029: community XSS — Fixed in 2.3.6-p1