NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-21026 — community-edition

MEDIUMFix: magento/magento2@a2eb7e2

CVE-2021-21026 is a medium-severity (CVSS 5.3) CWE-285 vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Magento improper authorization vulnerability in the integrations module

Also known asBIT-magento-2021-21026GHSA-crjc-2v9m-8w7r
Published
Updated
Affected
3 pkgs
Patched
2 / 3
Exploits
None indexed
Exploitation data as of Oct 23, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs78th percentile — riskier than 78% of all scored CVEsHighest risk
0.18%0.89%1.60%2.31%0.7%1.8%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘magento/community-edition🐘magento/community-edition🐘magento/project-community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by an improper authorization vulnerability in the integrations module. Successful exploitation could lead to unauthorized access to restricted resources by an unauthenticated attacker. Access to the admin console is required for successful exploitation.

Affected Packages

3 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-editionall versions2.3.6-p1composer require magento/community-edition:^2.3.6-p1
🐘Packagistmagento/community-edition≥ 2.4.0&&< 2.4.22.4.2composer require magento/community-edition:^2.4.2
🐘Packagistmagento/project-community-editionall versionsNo fix

Affected Products

1 product · 10 configurations
Application
magentomagento
< 2.3.6
3 versions
2.3.62.4.02.4.1

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.3.6-p1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-21026 is resolved across your whole dependency graph.

  3. Workarounds

    Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.

Frequently Asked Questions

Magento versions 2.4.1 (and earlier), 2.4.0-p1 (and earlier) and 2.3.6 (and earlier) are affected by an improper authorization vulnerability in the integrations module. Successful exploitation could lead to unauthorized access to restricted resources by an unauthenticated attacker. Access to the admin console is required for successful exploitation.
O3 Security · Impact-Aware SCA

Is CVE-2021-21026 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-21026: community-edition — Fixed in 2.3.6-p1