CVE-2021-20267 — neutron
HIGHCVE-2021-20267 is a high-severity (CVSS 7.1) CWE-345 vulnerability in neutron. A fix is available for neutron — see the affected versions and patch details below.
Openstack Neutron has Insufficient Verification of IPv6 addresses
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
neutron🐍neutron🐍neutronReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
A flaw was found in openstack-neutron's default Open vSwitch firewall rules. By sending carefully crafted packets, anyone in control of a server instance connected to the virtual switch can impersonate the IPv6 addresses of other systems on the network, resulting in denial of service or in some cases possibly interception of traffic intended for other destinations. Only deployments using the Open vSwitch driver are affected. Source: OpenStack project. Versions before openstack-neutron 15.3.3, openstack-neutron 16.3.1 and openstack-neutron 17.1.1 are affected.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | neutron | ≥ 16.0.0&&< 16.3.1 | 16.3.1pip install --upgrade 'neutron==16.3.1' |
| 🐍PyPI | neutron | all versions | 15.3.3pip install --upgrade 'neutron==15.3.3' |
| 🐍PyPI | neutron | ≥ 17.0.0&&< 17.1.1 | 17.1.1pip install --upgrade 'neutron==17.1.1' |
Affected Products
neutronopenstackopenstack platformredhatDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for neutron, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update neutron to 16.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-20267 is resolved across your whole dependency graph.
Workarounds
Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Mitigation for this issue is either not available or the currently available options do not meet the Red Hat Product Security criteria comprising ease of use and deployment, applicability to widespread installation base or stability.Source: Red Hat security advisory for CVE-2021-20267 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2021-20267 in your dependencies?
Find it across PyPI, including transitive dependencies.