CVE-2021-20186 — moodle
MEDIUMCVE-2021-20186 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.
Moodle Cross-site Scripting
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodleReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that if the TeX notation filter was enabled, additional sanitizing of TeX content was required to prevent the risk of stored XSS.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | moodle/moodle | ≥ 3.10&&< 3.10.1 | 3.10.1composer require moodle/moodle:^3.10.1 |
| 🐘Packagist | moodle/moodle | ≥ 3.9&&< 3.9.4 | 3.9.4composer require moodle/moodle:^3.9.4 |
| 🐘Packagist | moodle/moodle | ≥ 3.8&&< 3.8.7 | 3.8.7composer require moodle/moodle:^3.8.7 |
| 🐘Packagist | moodle/moodle | ≥ 3.5&&< 3.5.16 | 3.5.16composer require moodle/moodle:^3.5.16 |
Affected Products
moodlemoodleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update moodle/moodle to 3.10.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-20186 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2021-20186 in your dependencies?
Find it across Packagist, including transitive dependencies.