NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
MEDIUM severity

CVE-2021-20185 — moodle

MEDIUM

CVE-2021-20185 is a medium-severity (CVSS 5.3) Uncontrolled Resource Consumption vulnerability in moodle/moodle. A fix is available for moodle/moodle — see the affected versions and patch details below.

Moodle Client side denial of service via personal message

Also known asBIT-moodle-2021-20185GHSA-c3j6-33r4-89q3
Published
Updated
Affected
4 pkgs
Patched
4 / 4
Exploits
None indexed
Exploitation data as of Nov 2, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs72th percentile — riskier than 72% of all scored CVEsHighest risk
0.00%0.63%1.26%1.89%0.4%1.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle🐘moodle/moodle

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that messaging did not impose a character limit when sending messages, which could result in client-side (browser) denial of service for users receiving very large messages.

Affected Packages

4 total 4 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmoodle/moodle≥ 3.5&&< 3.5.163.5.16composer require moodle/moodle:^3.5.16
🐘Packagistmoodle/moodle≥ 3.8&&< 3.8.73.8.7composer require moodle/moodle:^3.8.7
🐘Packagistmoodle/moodle≥ 3.9&&< 3.9.43.9.4composer require moodle/moodle:^3.9.4
🐘Packagistmoodle/moodle≥ 3.10&&< 3.10.13.10.1composer require moodle/moodle:^3.10.1

Affected Products

1 product · 4 configurations
Application
moodlemoodle
≥ 3.9.0 && < 3.9.4
1 version
3.10.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for moodle/moodle, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update moodle/moodle to 3.5.16 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2021-20185 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Frequently Asked Questions

It was found in Moodle before version 3.10.1, 3.9.4, 3.8.7 and 3.5.16 that messaging did not impose a character limit when sending messages, which could result in client-side (browser) denial of service for users receiving very large messages.
O3 Security · Impact-Aware SCA

Is CVE-2021-20185 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2021-20185: moodle DoS — Fixed in 3.5.16