NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2020-9632 — community-edition

CRITICAL

CVE-2020-9632 is a critical-severity (CVSS 9.8) remote code execution vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Magento security mitigation bypass vulnerability

Also known asBIT-magento-2020-9632GHSA-6w29-x5j4-qhrw
Published
Updated
Affected
4 pkgs
Patched
2 / 4
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
7.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs94th percentile — riskier than 94% of all scored CVEsHighest risk
6.90%7.43%7.96%8.49%8.0%7.4%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

4 pkgs affected
🐘magento/community-edition🐘magento/community-edition🐘magento/core🐘magento/project-community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a security mitigation bypass vulnerability. Successful exploitation could lead to arbitrary code execution.

Affected Packages

4 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-editionall versionsNo fix
🐘Packagistmagento/community-edition≥ 2.3.0&&< 2.3.4-p22.3.4-p2composer require magento/community-edition:^2.3.4-p2
🐘Packagistmagento/coreall versions1.9.4.5composer require magento/core:^1.9.4.5
🐘Packagistmagento/project-community-editionall versionsNo fix

Affected Products

1 product · 6 configurations
Application
magentomagento
≥ 2.3.0 && ≤ 2.3.4
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    A fix is available for CVE-2020-9632; check the affected-versions list above or the advisory for the patched release of magento/community-edition, then make sure no transitive dependency still pins the vulnerable range.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a security mitigation bypass vulnerability. Successful exploitation could lead to arbitrary code execution.
O3 Security · Impact-Aware SCA

Is CVE-2020-9632 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-9632: community-edition RCE — Fixed in 2.3.4-p2