CVE-2020-9582 — community-edition
CRITICALCVE-2020-9582 is a critical-severity (CVSS 9.8) CWE-77 vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.
Magento command injection vulnerability
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
magento/community-edition🐘magento/community-edition🐘magento/core🐘magento/project-community-editionReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Magento versions 2.3.4 and earlier, 2.2.11 and earlier (see note), 1.14.4.4 and earlier, and 1.9.4.4 and earlier have a command injection vulnerability. Successful exploitation could lead to arbitrary code execution.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | magento/community-edition | ≥ 2.3.0&&< 2.3.4-p2 | 2.3.4-p2composer require magento/community-edition:^2.3.4-p2 |
| 🐘Packagist | magento/community-edition | all versions | 2.2.12composer require magento/community-edition:^2.2.12 |
| 🐘Packagist | magento/core | all versions | 1.9.4.5composer require magento/core:^1.9.4.5 |
| 🐘Packagist | magento/project-community-edition | all versions | No fix |
Affected Products
magentomagentoDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update magento/community-edition to 2.3.4-p2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-9582 is resolved across your whole dependency graph.
Workarounds
Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.
Frequently Asked Questions
Is CVE-2020-9582 in your dependencies?
Find it across Packagist, including transitive dependencies.