CVE-2020-8920 — gerrit-plugin-api
CVE-2020-8920 is a CWE-285 vulnerability in com.google.gerrit:gerrit-plugin-api. A fix is available for com.google.gerrit:gerrit-plugin-api — see the affected versions and patch details below.
Information leak in Gerrit
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
Real-World Exposure
com.google.gerrit:gerrit-plugin-api☕com.google.gerrit:gerrit-plugin-api☕com.google.gerrit:gerrit-plugin-api☕com.google.gerrit:gerrit-plugin-api☕com.google.gerrit:gerrit-plugin-api☕com.google.gerrit:gerrit-plugin-apiReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
An information leak vulnerability exists in Gerrit versions prior to 2.14.22, 2.15.21, 2.16.25, 3.0.15, 3.1.10, 3.2.5 where an overoptimization with the FilteredRepository wrapper skips the verification of access on All-Users repositories, allowing an attacker to get read access to all users' personal information associated with their accounts.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | com.google.gerrit:gerrit-plugin-api | all versions | 2.14.22com.google.gerrit:gerrit-plugin-api:2.14.22 |
| ☕Maven | com.google.gerrit:gerrit-plugin-api | ≥ 2.15.0&&< 2.15.21 | 2.15.21com.google.gerrit:gerrit-plugin-api:2.15.21 |
| ☕Maven | com.google.gerrit:gerrit-plugin-api | ≥ 2.16.0&&< 2.16.25 | 2.16.25com.google.gerrit:gerrit-plugin-api:2.16.25 |
| ☕Maven | com.google.gerrit:gerrit-plugin-api | ≥ 3.0.0&&< 3.0.15 | 3.0.15com.google.gerrit:gerrit-plugin-api:3.0.15 |
| ☕Maven | com.google.gerrit:gerrit-plugin-api | ≥ 3.1.0&&< 3.1.10 | 3.1.10com.google.gerrit:gerrit-plugin-api:3.1.10 |
| ☕Maven | com.google.gerrit:gerrit-plugin-api | ≥ 3.2.0&&< 3.2.5 | 3.2.5com.google.gerrit:gerrit-plugin-api:3.2.5 |
Affected Products
gerritgoogleDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.google.gerrit:gerrit-plugin-api, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update com.google.gerrit:gerrit-plugin-api to 2.14.22 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-8920 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2020-8920 in your dependencies?
Find it across Maven, including transitive dependencies.