NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
HIGH severity

CVE-2020-8141 — dot

HIGH

CVE-2020-8141 is a high-severity (CVSS 8.8) Code Injection vulnerability in dot. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for dot — see the affected versions and patch details below.

Improper Control of Generation of Code in doT

Also known asGHSA-297x-8xj4-vcxv
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs83th percentile — riskier than 83% of all scored CVEsHighest risk
0.54%1.26%1.98%2.70%1.0%2.2%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

569other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
dotnpm
1.1Mdownloads / week

Description

The dot package v1.1.2 uses Function() to compile templates. This can be exploited by the attacker if they can control the given template or if they can control the value set on Object.prototype.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmdotall versions1.1.3npm install dot@1.1.3

Affected Products

1 product · 1 configurations
Application
dotdot_project
1 version
1.1.2
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for dot, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update dot to 1.1.3 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-8141 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

The dot package v1.1.2 uses Function() to compile templates. This can be exploited by the attacker if they can control the given template or if they can control the value set on Object.prototype.
O3 Security · Impact-Aware SCA

Is CVE-2020-8141 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2020-8141: dot — Fixed in 1.1.3