NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2020-7938 — plone-restapi

HIGHFix: plone/plone.restapi#859

CVE-2020-7938 is a high-severity (CVSS 8.8) vulnerability in plone-restapi. A fix is available for plone-restapi — see the affected versions and patch details below.

Plone Privilege Escallation

Also known asGHSA-cjg3-q24h-9qwfPYSEC-2020-87PYSEC-2026-2889
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 30, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs74th percentile — riskier than 74% of all scored CVEsHighest risk
0.10%0.72%1.35%1.97%0.6%1.5%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐍plone-restapi🐍plone

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

plone.restapi in Plone 5.2.0 through 5.2.1 allows users with a certain privilege level to escalate their privileges up to the highest level.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIplone-restapiall versions6.2.1pip install --upgrade 'plone-restapi==6.2.1'
🐍PyPIplone≥ 5.2.0&&< 5.2.25.2.2pip install --upgrade 'plone==5.2.2'

Affected Products

1 product · 1 configurations
Application
ploneplone
≥ 5.2.0 && ≤ 5.2.1
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for plone-restapi, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update plone-restapi to 6.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-7938 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

plone.restapi in Plone 5.2.0 through 5.2.1 allows users with a certain privilege level to escalate their privileges up to the highest level.
O3 Security · Impact-Aware SCA

Is CVE-2020-7938 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2020-7938: plone-restapi — Fixed in 6.2.1