NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2020-7677 — thenify

CRITICALFix: thenables/thenify@0d94a24

CVE-2020-7677 is a critical-severity (CVSS 9.8) remote code execution vulnerability in org.webjars.npm:thenify. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.webjars.npm:thenify — see the affected versions and patch details below.

thenify before 3.3.1 made use of unsafe calls to `eval`.

Also known asGHSA-29xr-v42j-r956
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
2 known
Exploitation data as of Nov 6, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.1%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs82th percentile — riskier than 82% of all scored CVEsHighest risk
0.55%1.23%1.91%2.58%1.1%2.1%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected

How broadly this vulnerability is actually deployed: weekly install volume shows current usage, and reverse-dependency count shows how many other packages break if it stays unpatched.

722other npm packages depend on this — each one inherits the vulnerability until it's patched upstream
thenifynpm
68.8Mdownloads / week

Description

This affects the package thenify before 3.3.1. The name argument provided to the package can be controlled by users without any sanitization, and this is provided to the eval function without any sanitization.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.webjars.npm:thenifyall versions3.3.1org.webjars.npm:thenify:3.3.1
📦npmthenifyall versions3.3.1npm install thenify@3.3.1

Affected Products

3 products · 4 configurations
OS
debian linuxdebian
1 version
10.0
OS
fedorafedoraproject
2 versions
3637
Application
thenifythenify_project
< 3.3.1
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.webjars.npm:thenify, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.webjars.npm:thenify to 3.3.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-7677 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Versions of thenify prior to 3.3.1 made use of unsafe calls to `eval`. Untrusted user input could thus lead to arbitrary code execution on the host. The patch in version 3.3.1 removes calls to `eval`.
O3 Security · Impact-Aware SCA

Is CVE-2020-7677 in your dependencies?

Find it across Maven, npm, including transitive dependencies.

CVE-2020-7677: thenify RCE — Fixed in 3.3.1