NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
MEDIUM severity

CVE-2020-7658 — meinheld

MEDIUMFix: mopemope/meinheld@0cfa70b

CVE-2020-7658 is a medium-severity (CVSS 6.1) CWE-444 vulnerability in meinheld. A fix is available for meinheld — see the affected versions and patch details below.

meinheld vulnerable to HTTP Request Smuggling

Also known asGHSA-63h2-9cc8-fc7mPYSEC-2020-239SNYK-PYTHON-MEINHELD-569140
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Oct 27, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs52th percentile — riskier than 52% of all scored CVEsHighest risk
0.00%0.40%0.79%1.19%0.2%0.7%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐍meinheld

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

meinheld prior to 1.0.2 is vulnerable to HTTP Request Smuggling. HTTP pipelining issues and request smuggling attacks might be possible due to incorrect Content-Length and Transfer encoding header parsing.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPImeinheldall versions1.0.2pip install --upgrade 'meinheld==1.0.2'

Affected Products

1 product · 1 configurations
Application
meinheldmeinheld
< 1.0.2
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for meinheld, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update meinheld to 1.0.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-7658 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

meinheld prior to 1.0.2 is vulnerable to HTTP Request Smuggling. HTTP pipelining issues and request smuggling attacks might be possible due to incorrect Content-Length and Transfer encoding header parsing.
O3 Security · Impact-Aware SCA

Is CVE-2020-7658 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2020-7658: meinheld — Fixed in 1.0.2