NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
📦
📦 npm
Not in CISA KEV
CRITICAL severity

CVE-2020-6948 — hashbrown-cms

CRITICALFix: HashBrownCMS/hashbrown-cms@ff95bba

CVE-2020-6948 is a critical-severity (CVSS 9.8) OS Command Injection vulnerability in hashbrown-cms. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for hashbrown-cms — see the affected versions and patch details below.

HashBrown CMS RCE

Also known asGHSA-4gjv-5jjp-rcgh
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
1 known
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.8%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
2.28%2.88%3.47%4.07%3.3%2.8%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
📦hashbrown-cms

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects npm packages — download data is not available via public APIs for these ecosystems.

Description

A remote code execution issue was discovered in HashBrown CMS through 1.3.3. Server/Entity/Deployer/GitDeployer.js has a Service.AppService.exec call that mishandles the URL, repository, username, and password.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
📦npmhashbrown-cmsall versions1.3.4npm install hashbrown-cms@1.3.4

Affected Products

1 product · 1 configurations
Application
hashbrown cmshashbrowncms
≤ 1.3.3
range
Exploits & PoCs
1

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for hashbrown-cms, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update hashbrown-cms to 1.3.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-6948 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

A remote code execution issue was discovered in HashBrown CMS through 1.3.3. Server/Entity/Deployer/GitDeployer.js has a Service.AppService.exec call that mishandles the URL, repository, username, and password.
O3 Security · Impact-Aware SCA

Is CVE-2020-6948 in your dependencies?

Find it across npm, including transitive dependencies.

CVE-2020-6948: hashbrown-cms RCE — Fixed in 1.3.4