NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2020-5403 — reactor-netty-http

HIGH

CVE-2020-5403 is a high-severity (CVSS 7.5) Improper Input Validation vulnerability in io.projectreactor.netty:reactor-netty-http. A fix is available for io.projectreactor.netty:reactor-netty-http — see the affected versions and patch details below.

Improper Handling of Exceptional Conditions and Improper Input Validation in Reactor Netty

Also known asGHSA-hp5x-rqf7-43vf
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.00%0.55%1.10%1.66%0.3%1.2%May 26Oct 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕io.projectreactor.netty:reactor-netty-http

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Reactor Netty HttpServer, versions 0.9.3 and 0.9.4, is exposed to a URISyntaxException that causes the connection to be closed prematurely instead of producing a 400 response.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenio.projectreactor.netty:reactor-netty-http≥ 0.9.3&&< 0.9.50.9.5io.projectreactor.netty:reactor-netty-http:0.9.5

Affected Products

1 product · 2 configurations
Application
reactor nettybroadcom
2 versions
0.9.30.9.4

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for io.projectreactor.netty:reactor-netty-http, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update io.projectreactor.netty:reactor-netty-http to 0.9.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-5403 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Reactor Netty HttpServer, versions 0.9.3 and 0.9.4, is exposed to a URISyntaxException that causes the connection to be closed prematurely instead of producing a 400 response.
O3 Security · Impact-Aware SCA

Is CVE-2020-5403 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-5403: reactor-netty-http — Fixed in 0.9.5