CVE-2020-4054 is a high-severity (CVSS 7.3) Cross-site Scripting (XSS) vulnerability in sanitize. A fix is available for sanitize — see the affected versions and patch details below.
Cross-site Scripting in Sanitize
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
sanitizeReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.
Description
When HTML is sanitized using Sanitize's "relaxed" config or a custom config that allows certain elements, some content in a <math> or <svg> element may not be sanitized correctly even if math and svg are not in the allowlist.
You are likely to be vulnerable to this issue if you use Sanitize's relaxed config or a custom config that allows one or more of the following HTML elements:
iframemathnoembednoframesnoscriptplaintextscriptstylesvgxmp
Impact
Using carefully crafted input, an attacker may be able to sneak arbitrary HTML through Sanitize, potentially resulting in XSS (cross-site scripting) or other undesired behavior when that HTML is rendered in a browser.
Releases
This problem has been fixed in Sanitize 5.2.1.
Workarounds
If upgrading is not possible, a workaround is to override the default value of Sanitize's :remove_contents config option with the following value, which ensures that the contents of math and svg elements (among others) are removed entirely when those elements are not in the allowlist:
%w[iframe math noembed noframes noscript plaintext script style svg xmp]
For example, if you currently use Sanitize's relaxed config, you can create a custom config object that overrides the default value of :remove_contents like this:
custom_config = Sanitize::Config.merge(
Sanitize::Config::RELAXED,
:remove_contents => %w[iframe math noembed noframes noscript plaintext script style svg xmp]
)
You would then pass this custom config to Sanitize when sanitizing HTML.
For more information
If you have any questions or comments about this advisory:
- Open an issue in the Sanitize repo.
- See Sanitize's security policy.
Credits
Many thanks to Michal Bentkowski of Securitum for reporting this bug and helping to verify the fix.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 💎RubyGems | sanitize | ≥ 3.0.0&&< 5.2.1 | 5.2.1bundle update sanitize --conservative |
Affected Products
sanitizesanitize_projectDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for sanitize, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update sanitize to 5.2.1 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-4054 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2020-4054 in your dependencies?
Find it across RubyGems, including transitive dependencies.