NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
CRITICAL severity

CVE-2020-3716 — community-edition

CRITICAL

CVE-2020-3716 is a critical-severity (CVSS 9.8) Deserialization of Untrusted Data vulnerability in magento/community-edition. EPSS puts its 30-day exploitation probability at 14.0% (97th percentile). A fix is available for magento/community-edition — see the affected versions and patch details below.

Magento deserialization vulnerability

Also known asBIT-magento-2020-3716GHSA-9wc9-498w-h8xv
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 29, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
14.0%probability of exploitation in next 30 days
Moderate Risk0.00%
Lower risk than most CVEs97th percentile — riskier than 97% of all scored CVEsHighest risk
13.0%14.8%16.6%18.4%17.3%14.0%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
🐘magento/community-edition🐘magento/community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Magento versions 2.3.3 and earlier, 2.2.10 and earlier, 1.14.4.3 and earlier, and 1.9.4.3 and earlier have a deserialization of untrusted data vulnerability. Successful exploitation could lead to arbitrary code execution.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-edition≥ 2.2.0&&< 2.2.112.2.11composer require magento/community-edition:^2.2.11
🐘Packagistmagento/community-edition≥ 2.3.0&&< 2.3.42.3.4composer require magento/community-edition:^2.3.4

Affected Products

1 product · 6 configurations
Application
magentomagento
≥ 2.3.0 && ≤ 2.3.3
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.2.11 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-3716 is resolved across your whole dependency graph.

  3. Workarounds

    Do not deserialise data from untrusted sources: where the format allows it, restrict deserialisation to an explicit allowlist of expected types, and prefer a data-only format (JSON, Protobuf) over one that can reconstruct arbitrary objects until you can upgrade.

Frequently Asked Questions

Magento versions 2.3.3 and earlier, 2.2.10 and earlier, 1.14.4.3 and earlier, and 1.9.4.3 and earlier have a deserialization of untrusted data vulnerability. Successful exploitation could lead to arbitrary code execution.
O3 Security · Impact-Aware SCA

Is CVE-2020-3716 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-3716: community-edition RCE — Fixed in 2.2.11