NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
HIGH severity

CVE-2020-36655 — yii2-gii

HIGHFix: yiisoft/yii2-gii@ed61e0d

CVE-2020-36655 is a high-severity (CVSS 8.8) Code Injection vulnerability in yiisoft/yii2-gii. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for yiisoft/yii2-gii — see the affected versions and patch details below.

Command injection in yiisoft/yii2-gii

Also known asGHSA-3mpg-q26j-83j5
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
2 known
Exploitation data as of Nov 3, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

Proof-of-concept exploit code exists

  • CISA’s SSVC triage found public proof-of-concept exploit code for this CVE, though no confirmed active exploitation.
  • A successful exploit gives an attacker total control of the affected component, not partial access.

Exploitation and automatability from CISA’s SSVC triage for CVE-2020-36655.

EPSS Exploitation Probability

via FIRST.org ↗
1.5%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs75th percentile — riskier than 75% of all scored CVEsHighest risk
0.64%2.10%3.56%5.02%4.2%1.5%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
🐘yiisoft/yii2-gii

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Yii Yii2 Gii before 2.2.2 allows remote attackers to execute arbitrary code via the Generator.php messageCategory field. The attacker can embed arbitrary PHP code into the model file.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistyiisoft/yii2-giiall versions2.2.2composer require yiisoft/yii2-gii:^2.2.2

Affected Products

1 product · 1 configurations
Application
giiyiiframework
< 2.2.2
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for yiisoft/yii2-gii, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update yiisoft/yii2-gii to 2.2.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-36655 is resolved across your whole dependency graph.

  3. Workarounds

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

Frequently Asked Questions

Yii Yii2 Gii before 2.2.2 allows remote attackers to execute arbitrary code via the Generator.php messageCategory field. The attacker can embed arbitrary PHP code into the model file.
O3 Security · Impact-Aware SCA

Is CVE-2020-36655 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-36655: yii2-gii RCE — Fixed in 2.2.2