NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
💎
💎 RubyGems
Not in CISA KEV
CRITICAL severity

CVE-2020-36599 — omniauth

CRITICALFix: omniauth/omniauth@43a396f

CVE-2020-36599 is a critical-severity (CVSS 9.8) CWE-116 vulnerability in omniauth. A fix is available for omniauth — see the affected versions and patch details below.

OmniAuth's `lib/omniauth/failure_endpoint.rb` does not escape `message_key` value

Also known asGHSA-pm55-qfxr-h247
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
None indexed
Exploitation data as of Oct 28, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.2%probability of exploitation in next 30 days
Lower Risk+0.03%
Lower risk than most CVEs67th percentile — riskier than 67% of all scored CVEsHighest risk
0.12%0.63%1.15%1.66%0.6%1.2%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
💎omniauth💎omniauth

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects RubyGems packages — download data is not available via public APIs for these ecosystems.

Description

lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
💎RubyGemsomniauthall versions1.9.2bundle update omniauth --conservative
💎RubyGemsomniauth≥ 2.0.0.pre.rc1&&< 2.0.02.0.0bundle update omniauth --conservative

Affected Products

1 product · 2 configurations
Application
omniauthomniauth
< 1.9.2
1 version
2.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for omniauth, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update omniauth to 1.9.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-36599 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

lib/omniauth/failure_endpoint.rb in OmniAuth before 1.9.2 (and before 2.0) does not escape the message_key value.
O3 Security · Impact-Aware SCA

Is CVE-2020-36599 in your dependencies?

Find it across RubyGems, including transitive dependencies.

CVE-2020-36599: omniauth — Fixed in 1.9.2