CVE-2020-35908 — futures-util
MEDIUMCVE-2020-35908 is a medium-severity (CVSS 5.5) vulnerability in futures-util. A fix is available for futures-util — see the affected versions and patch details below.
Improper `Sync` implementation on `FuturesUnordered` in futures-utils can cause data corruption
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
futures-utilReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
An issue was discovered in the futures-util crate before 0.3.2 for Rust. FuturesUnordered can lead to data corruption because Sync is mishandled.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | futures-util | ≥ 0.3.0&&< 0.3.2 | 0.3.2cargo update -p futures-util --precise 0.3.2 |
Affected Products
future-utilsrust-langDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for futures-util, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update futures-util to 0.3.2 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-35908 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2020-35908 in your dependencies?
Find it across crates.io, including transitive dependencies.