CVE-2020-35711 — arc-swap
HIGHCVE-2020-35711 is a high-severity (CVSS 7.5) vulnerability in arc-swap. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for arc-swap — see the affected versions and patch details below.
Dangling reference in `access::Map` with Constant
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
arc-swap🦀arc-swapReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
An issue has been discovered in the arc-swap crate before 0.4.8 (and 1.x before 1.1.0) for Rust. Use of arc_swap::access::Map with the Constant test helper (or with a user-supplied implementation of the Access trait) could sometimes lead to dangling references being returned by the map.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | arc-swap | ≥ 0.4.2&&< 0.4.8 | 0.4.8cargo update -p arc-swap --precise 0.4.8 |
| 🦀crates.io | arc-swap | ≥ 1.0.0&&< 1.1.0 | 1.1.0cargo update -p arc-swap --precise 1.1.0 |
Affected Products
arc-swaparc-swap_projectResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for arc-swap, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update arc-swap to 0.4.8 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-35711 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2020-35711 in your dependencies?
Find it across crates.io, including transitive dependencies.