NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐍
🐍 PyPI
Not in CISA KEV
HIGH severity

CVE-2020-35662 — salt

HIGH

CVE-2020-35662 is a high-severity (CVSS 7.4) CWE-295 vulnerability in salt. A fix is available for salt — see the affected versions and patch details below.

SaltStack Salt Improper SSL Certificate Validation

Also known asGHSA-qx72-q6w3-qgc7PYSEC-2021-75
Published
Updated
Affected
9 pkgs
Patched
8 / 9
Exploits
None indexed
Exploitation data as of Nov 5, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

Exploitation Status

No confirmed exploitation observed yet

  • A successful exploit gives an attacker total control of the affected component, not partial access.
  • CISA’s own triage has not observed active exploitation or public proof-of-concept code for this CVE as of its last assessment.

Exploitation and automatability from CISA’s SSVC triage for CVE-2020-35662.

EPSS Exploitation Probability

via FIRST.org ↗
3.0%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs87th percentile — riskier than 87% of all scored CVEsHighest risk
0.08%1.27%2.46%3.65%0.8%3.0%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

9 pkgs affected
🐍salt🐍salt🐍salt🐍salt🐍salt🐍salt🐍salt🐍salt+1 more

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.

Description

In SaltStack Salt before 3002.5, when authenticating to services using certain modules, the SSL certificate is not always validated.

Affected Packages

9 total 8 fixed
EcosystemPackageVulnerable rangeFix
🐍PyPIsaltall versions2015.8.13pip install --upgrade 'salt==2015.8.13'
🐍PyPIsalt≥ 2016.3.0&&< 2016.11.52016.11.5pip install --upgrade 'salt==2016.11.5'
🐍PyPIsalt≥ 2016.11.7&&< 2016.11.102016.11.10pip install --upgrade 'salt==2016.11.10'
🐍PyPIsalt≥ 2017.5.0&&< 2017.7.82017.7.8pip install --upgrade 'salt==2017.7.8'
🐍PyPIsalt≥ 2018.2.0No fix
🐍PyPIsalt≥ 2019.2.0&&< 2019.2.82019.2.8pip install --upgrade 'salt==2019.2.8'

Affected Products

3 products · 21 configurations
OS
debian linuxdebian
3 versions
9.010.011.0
OS
fedorafedoraproject
3 versions
323334
Application
saltsaltstack
≥ 3002 && ≤ 2018.3.5
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for salt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update salt to 2015.8.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-35662 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

In SaltStack Salt before 3002.5, when authenticating to services using certain modules, the SSL certificate is not always validated.
O3 Security · Impact-Aware SCA

Is CVE-2020-35662 in your dependencies?

Find it across PyPI, including transitive dependencies.

CVE-2020-35662: salt — Fixed in 2015.8.13