NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
CRITICAL severity

CVE-2020-35476 — opentsdb

CRITICAL

CVE-2020-35476 is a critical-severity (CVSS 9.8) OS Command Injection vulnerability in net.opentsdb:opentsdb. 3 public exploit or proof-of-concept references are indexed, so weaponization risk is real. The records list no fixed version yet; check the vendor advisory below and apply the mitigations in the meantime.

OS Command Injection in OpenTSDB

Also known asGHSA-hv53-q76c-7f8c
Published
Updated
Affected
1 pkg
Patched
See advisory
Exploits
3 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
85.3%probability of exploitation in next 30 days
Very High Risk0.00%
Lower risk than most CVEs100th percentile — riskier than 100% of all scored CVEsHighest risk
82.7%87.4%92.2%96.9%94.3%85.3%May 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕net.opentsdb:opentsdb

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A remote code execution vulnerability occurs in OpenTSDB through 2.4.0 via command injection in the yrange parameter. The yrange value is written to a gnuplot file in the /tmp directory. This file is then executed via the mygnuplot.sh shell script. (tsd/GraphHandler.java attempted to prevent command injections by blocking backticks but this is insufficient.)

Affected Packages

1 total
EcosystemPackageVulnerable rangeFix
☕Mavennet.opentsdb:opentsdball versionsNo fix

Affected Products

1 product · 1 configurations
Application
opentsdbopentsdb
≤ 2.4.0
range
Exploits & PoCs
3

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for net.opentsdb:opentsdb, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Remediation status

    The records we use list no patched version of net.opentsdb:opentsdb for CVE-2020-35476. Check the maintainer's advisory, and where your build allows, override or pin the dependency away from the vulnerable range.

  3. Mitigate without a patch

    Stop passing untrusted input into the interpreter or shell: call the affected binary with an argument array rather than a composed command string, reject anything outside a strict allowlist of expected values, and run the component under an account that cannot reach beyond the work it legitimately does.

How to detect CVE-2020-35476

A community-maintained Nuclei template exists for this CVE. You can scan for it directly:

nuclei -id cve-2020-35476 -u https://target
Template
OpenTSDB <=2.4.0 - Remote Code Execution
Severity
critical
Impact
Successful exploitation of this vulnerability could allow an attacker to execute arbitrary code on the affected system.
Remediation
Upgrade OpenTSDB to a version higher than 2.4.0 to mitigate this vulnerability.

Template by ProjectDiscovery nuclei-templates (pikpikcu), MIT licensed. View the full template. Scan only systems you are authorised to test.

Frequently Asked Questions

A remote code execution vulnerability occurs in OpenTSDB through 2.4.0 via command injection in the yrange parameter. The yrange value is written to a gnuplot file in the /tmp directory. This file is then executed via the mygnuplot.sh shell script. (tsd/GraphHandler.java attempted to prevent command injections by blocking backticks but this is insufficient.)
O3 Security · Impact-Aware SCA

Is CVE-2020-35476 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-35476: opentsdb: OS Command Injection