CVE-2020-28247 is a medium-severity (CVSS 5.3) vulnerability in lettre. A fix is available for lettre — see the affected versions and patch details below.
Argument injection in lettre
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
CVE-2020-28247 by exploitation likelihood (EPSS) against impact (CVSS). Outside the shaded patch-first corner.
Where this sits among everything scored
Of 395,249 CVEs with a current EPSS score, this one falls in the < 10% band (highlighted). Counts from FIRST.org, log-scaled.
Real-World Exposure
lettre🦀lettre🦀lettreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects crates.io packages — download data is not available via public APIs for these ecosystems.
Description
Impact
Affected versions of lettre allowed argument injection to the sendmail command. It was possible, using forged to addresses, to pass arbitrary arguments to the sendmail executable.
Depending on the implementation (original sendmail, postfix, exim, etc.) it could be possible in some cases to write email data into abritrary files (using sendmail's logging features).
NOTE: This vulnerability only affects the sendmail transport. Others, including smtp, are not affected.
Fix
The flaw is corrected by modifying the executed command to stop parsing arguments before passing the destination addresses.
References
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🦀crates.io | lettre | ≥ 0.9.0&&< 0.9.5 | 0.9.5cargo update -p lettre --precise 0.9.5 |
| 🦀crates.io | lettre | ≥ 0.8.0&&< 0.8.4 | 0.8.4cargo update -p lettre --precise 0.8.4 |
| 🦀crates.io | lettre | ≥ 0.7.0&&< 0.7.1 | 0.7.1cargo update -p lettre --precise 0.7.1 |
Affected Products
lettrelettreDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for lettre, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update lettre to 0.9.5 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-28247 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2020-28247 in your dependencies?
Find it across crates.io, including transitive dependencies.