NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
HIGH severity

CVE-2020-25644 — wildfly-openssl-natives-p…

HIGHFix: wildfly-security/wildfly-openssl-natives#4

CVE-2020-25644 is a high-severity (CVSS 7.5) CWE-401 vulnerability in org.wildfly.openssl:wildfly-openssl-natives-parent. A fix is available for org.wildfly.openssl:wildfly-openssl-natives-parent — see the affected versions and patch details below.

Wildfly-OpenSSL memory leak flaw

Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
2.4%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs84th percentile — riskier than 84% of all scored CVEsHighest risk
0.00%0.98%1.96%2.94%0.5%2.4%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕org.wildfly.openssl:wildfly-openssl-natives-parent

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

A memory leak flaw was found in WildFly OpenSSL in versions prior to 1.1.3.Final, where it removes an HTTP session. It may allow the attacker to cause OOM leading to a denial of service. The highest threat from this vulnerability is to system availability.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.wildfly.openssl:wildfly-openssl-natives-parentall versions1.1.3.Finalorg.wildfly.openssl:wildfly-openssl-natives-parent:1.1.3.Final

Affected Products

10 products · 10 configurations
Application
oncommand insightnetapp
all
Application
oncommand workflow automationnetapp
all
Application
service level managernetapp
all
Application
data gridredhat
1 version
8.0
Application
jboss data gridredhat
1 version
7.0.0
Application
jboss enterprise application platformredhat
1 version
7.0.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.wildfly.openssl:wildfly-openssl-natives-parent, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.wildfly.openssl:wildfly-openssl-natives-parent to 1.1.3.Final or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-25644 is resolved across your whole dependency graph.

  3. Workarounds

    Cap what an attacker can consume: apply request size, rate and timeout limits in front of the affected component, and run it with memory and CPU limits so exhaustion degrades one worker rather than the whole service.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatImportant
Workaround published by Red Hat
There is currently no known mitigation for this issue.
Source: Red Hat security advisory for CVE-2020-25644 (CC BY 4.0)
ProductFixed inAdvisory
EAP 7.3.3wildfly-openssl-natives-parentRHSA-2020:4923
Red Hat Data Grid 7.3.8wildfly-opensslRHSA-2020:5410
Red Hat Data Grid 8.1.1wildfly-opensslRHSA-2021:0433
Red Hat Fuse 7.9wildfly-opensslRHSA-2021:3140
Red Hat JBoss Enterprise Application Platform 7wildfly-openssl-natives-parentRHSA-2020:4257
Red Hat JBoss Enterprise Application Platform 7see advisoryRHSA-2020:5344
Red Hat JBoss Enterprise Application Platform 7.1 EUS for RHEL 7eap7-glassfish-el-0:3.0.1-4.b08_redhat_00005.1.ep7.el7RHSA-2025:9582
Red Hat JBoss Enterprise Application Platform 7.3 for RHEL 6eap7-wildfly-openssl-linux-x86_64-0:1.0.11-1.Final_redhat_00001.1.el6eapRHSA-2020:4256

Frequently Asked Questions

A memory leak flaw was found in WildFly OpenSSL in versions prior to 1.1.3.Final, where it removes an HTTP session. It may allow the attacker to cause OOM leading to a denial of service. The highest threat from this vulnerability is to system availability.
O3 Security · Impact-Aware SCA

Is CVE-2020-25644 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-25644: DoS — Fixed in 1.1.3.Final