CVE-2020-25592 — salt
CRITICALCVE-2020-25592 is a critical-severity (CVSS 9.8) Improper Authentication vulnerability in salt. 1 public exploit or proof-of-concept reference is indexed, so weaponization risk is real. A fix is available for salt — see the affected versions and patch details below.
SaltStack Salt Improper Validation of eauth credentials and tokens in salt-netapi
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
salt🐍salt🐍salt🐍salt🐍salt🐍salt🐍salt🐍salt+1 moreReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects PyPI packages — download data is not available via public APIs for these ecosystems.
Description
In SaltStack Salt through 3002, salt-netapi improperly validates eauth credentials and tokens. A user can bypass authentication and invoke Salt SSH.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐍PyPI | salt | all versions | 2015.8.13pip install --upgrade 'salt==2015.8.13' |
| 🐍PyPI | salt | ≥ 2016.3.0&&< 2016.3.8 | 2016.3.8pip install --upgrade 'salt==2016.3.8' |
| 🐍PyPI | salt | ≥ 2016.11.0&&< 2016.11.10 | 2016.11.10pip install --upgrade 'salt==2016.11.10' |
| 🐍PyPI | salt | ≥ 2017.5.0&&< 2017.7.8 | 2017.7.8pip install --upgrade 'salt==2017.7.8' |
| 🐍PyPI | salt | ≥ 2018.2.0&&< 2018.3.5 | 2018.3.5pip install --upgrade 'salt==2018.3.5' |
| 🐍PyPI | salt | ≥ 2019.2.0&&< 2019.2.7 | 2019.2.7pip install --upgrade 'salt==2019.2.7' |
Affected Products
debian linuxdebiansaltsaltstackResearch use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.
Detection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for salt, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update salt to 2015.8.13 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-25592 is resolved across your whole dependency graph.
Workarounds
Put an independent control in front of the weakness: restrict the affected endpoint or interface to trusted networks, require an additional authentication factor or proxy-level check, and invalidate existing sessions and credentials in case the flaw has already been used.
Fixing This On Your OS
If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.
Red Hat Ceph Storage 2 shipped salt for the usage of Red Hat Storage Console 2 (RHSCON-2), which required salt to administrate ceph nodes. RHSCON-2 has reached End Of Life, hence salt is no longer used and supported. Therefore, the salt package provided by Red Hat Ceph Storage 2 has been marked as 'will not fix'.
Red Hat has investigated whether a possible mitigation exists for this issue, and has not been able to identify a practical example. Please update as soon as possible.Source: Red Hat security advisory for CVE-2020-25592 (CC BY 4.0)
Frequently Asked Questions
Is CVE-2020-25592 in your dependencies?
Find it across PyPI, including transitive dependencies.