NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
🐘
🐘 Packagist
Not in CISA KEV
LOW severity

CVE-2020-24403 — community-edition

LOW

CVE-2020-24403 is a low-severity (CVSS 2.7) CWE-285 vulnerability in magento/community-edition. A fix is available for magento/community-edition — see the affected versions and patch details below.

Magento incorrect user permissions vulnerability within the Inventory component

Also known asBIT-magento-2020-24403GHSA-39rw-4m66-82gf
Published
Updated
Affected
3 pkgs
Patched
2 / 3
Exploits
None indexed
Exploitation data as of Oct 24, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
1.6%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs76th percentile — riskier than 76% of all scored CVEsHighest risk
0.00%0.71%1.42%2.13%0.2%1.6%Apr 26Aug 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

3 pkgs affected
🐘magento/community-edition🐘magento/community-edition🐘magento/project-community-edition

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.

Description

Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect user permissions vulnerability within the Inventory component. This vulnerability could be abused by authenticated users with Inventory and Source permissions to make unauthorized changes to inventory source data via the REST API.

Affected Packages

3 total 2 fixed
EcosystemPackageVulnerable rangeFix
🐘Packagistmagento/community-editionall versions2.3.6composer require magento/community-edition:^2.3.6
🐘Packagistmagento/community-edition≥ 2.4.0&&< 2.4.12.4.1composer require magento/community-edition:^2.4.1
🐘Packagistmagento/project-community-editionall versionsNo fix

Affected Products

1 product · 8 configurations
Application
magentomagento
< 2.3.5
2 versions
2.3.52.4.0

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for magento/community-edition, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update magento/community-edition to 2.3.6 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-24403 is resolved across your whole dependency graph.

  3. Workarounds

    If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.

Frequently Asked Questions

Magento version 2.4.0 and 2.3.5p1 (and earlier) are affected by an incorrect user permissions vulnerability within the Inventory component. This vulnerability could be abused by authenticated users with Inventory and Source permissions to make unauthorized changes to inventory source data via the REST API.
O3 Security · Impact-Aware SCA

Is CVE-2020-24403 in your dependencies?

Find it across Packagist, including transitive dependencies.

CVE-2020-24403: community-edition — Fixed in 2.3.6