CVE-2020-2279 is a critical-severity (CVSS 9.9) remote code execution vulnerability in org.jenkins-ci.plugins:script-security. A fix is available for org.jenkins-ci.plugins:script-security — see the affected versions and patch details below.
Sandbox bypass vulnerability in Jenkins Script Security Plugin
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
org.jenkins-ci.plugins:script-security☕org.jenkins-ci.plugins:script-securityReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.
Description
Jenkins Script Security Plugin provides a sandbox feature that allows low privileged users to define scripts, including Pipelines, that are generally safe to execute. Calls to code defined inside a sandboxed script are intercepted, and various allowlists are checked to determine whether the call is to be allowed.
In Script Security Plugin 1.75 and 1.66.5, any calls from outside a sandboxed script to code defined inside a sandboxed script were always allowed. As sandboxed scripts can communicate their results through script return values and similar mechanisms, this could result in code defined inside of a sandboxed script to be called without sandbox protection.
This vulnerability allows attackers with permission to define and run sandboxed scripts, including Pipelines, to bypass the sandbox protection and execute arbitrary code in the context of the Jenkins controller JVM.
Script Security Plugin 1.75 and 1.66.5 will prevent code defined inside a sandbox from being invoked outside a sandboxed script.
In rare cases, invocations of sandboxed scripts may begin failing if the script return value or script binding include code defined in the sandbox and is further processed by the calling code. To resolve this issue, the affected values need to be converted inside the sandboxed script to a known safe type, such as String.
For compatibility with this change, the following plugins should be upgraded to the versions specified:
- Email Extension Plugin should be updated to version 2.77 or newer.
- Warnings Next Generation Plugin should be updated to version 8.4.3 or newer.
- Warnings Plugin should be updated to version 5.0.2 or newer.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| ☕Maven | org.jenkins-ci.plugins:script-security | ≥ 1.67&&< 1.75 | 1.75org.jenkins-ci.plugins:script-security:1.75 |
| ☕Maven | org.jenkins-ci.plugins:script-security | all versions | 1.66.5org.jenkins-ci.plugins:script-security:1.66.5 |
Affected Products
script securityjenkinsDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.plugins:script-security, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update org.jenkins-ci.plugins:script-security to 1.75 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2279 is resolved across your whole dependency graph.
Workarounds
If you can't upgrade right away: gate or disable the affected feature, validate untrusted input at the boundary, and avoid passing attacker-controlled data into the vulnerable path. O3's runtime protection blocks exploitation in production as an interim safeguard until the upgrade lands.
Frequently Asked Questions
Is CVE-2020-2279 in your dependencies?
Find it across Maven, including transitive dependencies.