CVE-2020-22765 — nukeviet
MEDIUMCVE-2020-22765 is a medium-severity (CVSS 6.1) Cross-site Scripting (XSS) vulnerability in nukeviet/nukeviet. A fix is available for nukeviet/nukeviet — see the affected versions and patch details below.
NukeViet Cross-site Scripting via the editor in the News module
EPSS Exploitation Probability
Probability of exploitation in the next 30 days, from FIRST.org EPSS.
How urgent is this, really
Where this sits among everything scored
Real-World Exposure
nukeviet/nukevietReal-time download stats are indexed for npm and PyPI packages. This vulnerability affects Packagist packages — download data is not available via public APIs for these ecosystems.
Description
Cross Site Scripting (XSS) vulnerability in NukeViet cms 4.4.0 via the editor in the News module.
Affected Packages
| Ecosystem | Package | Vulnerable range | Fix |
|---|---|---|---|
| 🐘Packagist | nukeviet/nukeviet | ≥ 4.4.0&&< 4.4.01 | 4.4.01composer require nukeviet/nukeviet:^4.4.01 |
Affected Products
nukevietnukevietDetection & mitigation playbook
Open-source dependencyDetect
Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for nukeviet/nukeviet, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.
Fix
Update nukeviet/nukeviet to 4.4.01 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-22765 is resolved across your whole dependency graph.
Workarounds
Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.
Frequently Asked Questions
Is CVE-2020-22765 in your dependencies?
Find it across Packagist, including transitive dependencies.