NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2020-2236 — yet-another-build-visuali…

MEDIUMFix: jenkinsci/yet-another-build-visualizer-plugin@0e6db61

CVE-2020-2236 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer. A fix is available for com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer — see the affected versions and patch details below.

Stored XSS vulnerability in Jenkins Yet Another Build Visualizer Plugin

Also known asGHSA-3mwj-7vmq-w43p
Published
Updated
Affected
1 pkg
Patched
1 / 1
Exploits
None indexed
Exploitation data as of Nov 4, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
0.7%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs55th percentile — riskier than 55% of all scored CVEsHighest risk
0.00%0.41%0.82%1.23%0.2%0.7%May 26Sep 26Nov 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

1 pkg affected
☕com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Yet Another Build Visualizer Plugin 1.11 and earlier does not escape tooltip content.

This results in a stored cross-site scripting (XSS) vulnerability exploitable by users with Run/Update permission.

Yet Another Build Visualizer Plugin 1.12 escapes tooltip content.

Affected Packages

1 total 1 fixed
EcosystemPackageVulnerable rangeFix
☕Mavencom.axis.system.jenkins.plugins.downstream:yet-another-build-visualizerall versions1.12com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer:1.12

Affected Products

1 product · 1 configurations
Application
yet another build visualizerjenkins
≤ 1.11
range

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update com.axis.system.jenkins.plugins.downstream:yet-another-build-visualizer to 1.12 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2236 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Frequently Asked Questions

Yet Another Build Visualizer Plugin 1.11 and earlier does not escape tooltip content. This results in a stored cross-site scripting (XSS) vulnerability exploitable by users with Run/Update permission. Yet Another Build Visualizer Plugin 1.12 escapes tooltip content.
O3 Security · Impact-Aware SCA

Is CVE-2020-2236 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2236: yet-another-build XSS — Fixed in 1.12