NIST deprecates RSA-2048 from 2030. Find every one of them before attackers do.
☕
☕ Maven
Not in CISA KEV
MEDIUM severity

CVE-2020-2231 — jenkins-core

MEDIUMFix: jenkinsci/jenkins@29c9a8f

CVE-2020-2231 is a medium-severity (CVSS 5.4) Cross-site Scripting (XSS) vulnerability in org.jenkins-ci.main:jenkins-core. 2 public exploit or proof-of-concept references are indexed, so weaponization risk is real. A fix is available for org.jenkins-ci.main:jenkins-core — see the affected versions and patch details below.

Improper Neutralization of Input During Web Page Generation in Jenkins

Also known asBIT-jenkins-2020-2231GHSA-jpvq-v729-7j2h
Published
Updated
Affected
2 pkgs
Patched
2 / 2
Exploits
2 known
Exploitation data as of Oct 31, 2026 · OSV.dev, NVD, FIRST.org (EPSS)

EPSS Exploitation Probability

via FIRST.org ↗
5.3%probability of exploitation in next 30 days
Lower Risk0.00%
Lower risk than most CVEs93th percentile — riskier than 93% of all scored CVEsHighest risk
0.00%2.25%4.50%6.75%0.5%5.3%May 26Sep 26Oct 26

Probability of exploitation in the next 30 days, from FIRST.org EPSS.

How urgent is this, really

Where this sits among everything scored

Real-World Exposure

2 pkgs affected
☕org.jenkins-ci.main:jenkins-core☕org.jenkins-ci.main:jenkins-core

Real-time download stats are indexed for npm and PyPI packages. This vulnerability affects Maven packages — download data is not available via public APIs for these ecosystems.

Description

Jenkins 2.251 and earlier, LTS 2.235.3 and earlier does not escape the remote address of the host starting a build via 'Trigger builds remotely', resulting in a stored cross-site scripting (XSS) vulnerability exploitable by users with Job/Configure permission or knowledge of the Authentication Token.

Affected Packages

2 total 2 fixed
EcosystemPackageVulnerable rangeFix
☕Mavenorg.jenkins-ci.main:jenkins-coreall versions2.235.4org.jenkins-ci.main:jenkins-core:2.235.4
☕Mavenorg.jenkins-ci.main:jenkins-core≥ 2.237&&< 2.2522.252org.jenkins-ci.main:jenkins-core:2.252

Affected Products

1 product · 2 configurations
Application
jenkinsjenkins
≤ 2.251
range
Exploits & PoCs
2

Research use only. For defensive security, authorized penetration testing, and academic research only. Never execute exploit code against systems without explicit written authorization.

EDB-49244webappsjava

Jenkins 2.235.3 - 'X-Forwarded-For' Stored XSS

by gx1 · Dec 14, 2020

Detection & mitigation playbook

Open-source dependency
  1. Detect

    Scan your dependency tree (package-lock.json, pnpm-lock.yaml, requirements.txt, go.sum, etc.) for org.jenkins-ci.main:jenkins-core, including transitive dependencies — a direct dependency you never call can still pull in a vulnerable version.

  2. Fix

    Update org.jenkins-ci.main:jenkins-core to 2.235.4 or later, then make sure no transitive (indirect) dependency still pins the vulnerable range — O3 confirms CVE-2020-2231 is resolved across your whole dependency graph.

  3. Workarounds

    Escape or sanitise the affected output on the server side rather than relying on client-side filtering, and add a Content-Security-Policy that blocks inline script execution so injected markup cannot run even if it reaches the page.

Fixing This On Your OS

If you run this on a Linux distribution, patch through your package manager against the distro's own security advisory below — it tracks the exact backported fix for your release, which can ship on a different timeline (and sometimes a different severity) than the upstream project.

Red HatModerate
ProductFixed inAdvisory
Red Hat OpenShift Container Platform 3.11jenkins-0:2.235.5.1600415953-1.el7RHSA-2020:4223
Red Hat OpenShift Container Platform 4.3jenkins-0:2.235.5.1600415514-1.el7RHSA-2020:3808
Red Hat OpenShift Container Platform 4.4openshift4/ose-jenkins:v4.4.0-202009260441.p0RHSA-2020:4220
Red Hat OpenShift Container Platform 4.5jenkins-0:2.235.5.1600414805-1.el7RHSA-2020:3841
Red Hat OpenShift Container Platform 4.6openshift4/ose-aws-ebs-csi-driver-rhel8:v4.6.0-202010311441.p0RHBA-2020:4339

Frequently Asked Questions

Jenkins 2.251 and earlier, LTS 2.235.3 and earlier does not escape the remote address of the host starting a build via 'Trigger builds remotely', resulting in a stored cross-site scripting (XSS) vulnerability exploitable by users with Job/Configure permission or knowledge of the Authentication Token.
O3 Security · Impact-Aware SCA

Is CVE-2020-2231 in your dependencies?

Find it across Maven, including transitive dependencies.

CVE-2020-2231: jenkins-core XSS — Fixed in 2.235.4